Юрий Г-ко (chieftain_yu) wrote,
Юрий Г-ко
chieftain_yu

Category:
В комменты призываются краснаглазики.

Есть у меня Raspberry Pi под Raspbian (форк Debian).
И долгое время все было хорошо - в том числе автомонтировался в нужную мне точку внешний USB-диск.
Но в процессе смены сетевого оборудования что-то пошло не так. Теперь автомонтаж не работает. Во всяком случае, не как мне надо.

Если /dev/sda2 не смонтирован никуда, то он прекрасно монтируется командой:
sudo mount -t ntfs -o defaults,nls=utf8,file_mode=0777 /dev/sda2 /ExtDisk/
Все пашет, траляля.

Если вписать в fstab такую строку:
/dev/sda2 /ExtDisk ntfs defaults,nls=utf8,file_mode=0777 0 2
то не пашет нихрена:
dir /ExtDisk
dir: невозможно получить доступ к '/ExtDisk': Конечная точка передачи не подсоединена
В выводе mount все типа прицеплено.

Если закомментить строку, Raspbian автомонтирует /dev/sda2 в /media/pi/(UUID), и там все видно.

Если после этого сказать:
sudo umount /dev/sda2
sudo mount -t ntfs -o defaults,nls=utf8,file_mode=0777 /dev/sda2 /ExtDisk/
то все работает.

Но если включить в скрипт, вызываемый из rc.local, ровно те же команды, то в выводе mount все типа подцеплено, но на деле нихрена не работает. До ручного ввода тех же команд.

Куды бечь, чего читать?
Абстрактные маны и выдачи гугла уже читал, просьба помочь с диагностикой.
Tags: Вопросы о жизни, Линукс, Просьбы
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 1 comment